Jotform Outage

Incident Report for Jotform

Resolved

The issue has been identified and resolved. All systems should be functional now.
Posted Feb 09, 2026 - 09:26 PST

Investigating

We are currently investigating the issue.
Posted Feb 09, 2026 - 07:33 PST