Jotform Outage
Incident Report for Jotform
Resolved
Jotform is now operational after experiencing a temporary outage.
Posted Aug 24, 2023 - 01:30 PDT
Investigating
We are currently investigating this issue.
Posted Aug 24, 2023 - 01:06 PDT