Global Elevated Errors
Incident Report for Jotform
Resolved
We're experiencing an elevated level of errors and are currently looking into the issue.

Issue is solved at 02:39 PDT
Posted Jun 30, 2021 - 02:28 PDT